Decay Frust auf Oxide Server sucht hilfe

    • Decay Frust auf Oxide Server sucht hilfe

      Hallo

      Wie der Titel schon sagt suche ich Hilfe was das "Decay" auf meinem Dedicated Server mit Oxide angeht.
      Und zwar habe ich vor ein paar Tagen wieder mal einen kleinen Server für mich erstellt und dieser lies sich auch ganz gut bespielen.
      Doch als ich anfing mir ein Häuschen zu bauen zerfielen die Bauteile so schnell das ich gar nicht erst dazu kam den Hausbau ganz zu beenden ?(
      Darauf hin habe ich Oxide aufgespielt aber ich finde einfach kein Plugin zum deaktivieren oder regeln des Decay.
      Gibt es sowas denn gar nicht oder wie kann ich diesem Problem Herr werden ?
      Ich fand einige Parameter die man wohl irgendwo in irgendwelche Files einfügen soll aber eine Ahnung wie oder wo ich das tun muss habe ich nicht da es auch keine Erklärung dazu gibt.

      Ich würde mich sehr freuen zu erfahren wie ich Decay deaktivieren, danke im Voraus !
    • Danke für den Tipp, aber diesen Thread hatte ich mir schon durchgenommen. Mein Server ist Oxide, nicht Vanilla und eine wirkliche Erläuterung wie man es anstellt ist dort leider auch nicht zu lesen.
      Bin noch neu im Modden von RUST Servern, habe das noch nie vorher versucht.
    • Auf das erste bin ich auf meiner Suche auch schon oft gestoßen. Das wäre genau das richtige. Allerdings habe ich keinen Schimmer wie oder wo ich diese Zeilen eintragen muss damit sie wirken.
      Es scheint auch das man dafür dieses rcon Tool benötigt ohne das ich eigentlich auskommen wollte, was der Grund war wieso ich auf Oxide gesetzt hatte

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Brave Jake ()

    • such nach upkeep

      Quellcode

      1. "upkeep_period_minutes 4320",
      2. "duration_twig 24",
      3. "duration_wood 48",
      4. "duration_stone 72",
      5. "duration_metal 96",
      6. "duration_toptier 120",
      7. "upkeep_heal_scale 5",

      sind zum beispiel ganz gut bestpielbare UpKeep Zeiten... 1/5 der UpKeep Kosten bei gleich beibender Heal Rate... Zerfall je nach Struktur zwischen 1-5 Tagen sobald der Bauschrank keine Ressourcen mehr hat.

      Um es ganz zu deaktivieren einfach

      Quellcode

      1. decay.upkeep false


      Brauchst keine Plugins...

      Alle Infos zu UpKeep findest du z.B. hier
    • Wenn du ohnehin Oxide drauf hast empfehle ich dir StartupCommands und AutomaticClientCommands

      In StartupCommands trägst du folgendes ein:
      "decay.upkeep false"

      Und bei AutoClientCommands
      "gametip.hidegametip"

      Das Hidegametip macht zwar nicht das "Building Decay" rechts unten in der Ecke weg, aber die hässligen, riesigen ToolTips (U.a. dann auch das man Ressourcen in den Bauschrank füllen soll) bei allen Usern die auf den Server connecten.


      Wenn du n startup Script hast bzw zugriff drauf, müsste es auch getan sein wenn du einfach decay.upkeep false dort einträgst.

      Wenn du weder Zugriff auf das Script hast noch oxide nutzt bleibt dir nur nach jedem Restart F1 -> decay.upkeep false
    • Da es mein eigener kleiner Server ist hab ich zugriff auf diese Script. Habe mich schon zum Admin gemacht. Wenn ich +decay.upkeep false ins startup Script dazuschreiben will wo auch der Autosave Interval und der Seed drinstehn muss ich den Server neu erstellen nehme ich an ?

      Hab nun mal die bestehende Startdatai mit einer neuen mit zusatzlichem "+decay.upkeep false" überschrieben und den Server gestartet. Aber kaum nehme ich alles Holz aus dem Werkzeugschrank hab ich wieder die Meldung das ich einen Werzeugschrank aufstellen soll und mein Gebäude am decayen ist

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Brave Jake ()

    • Jop, die Meldung ist nochmal... den blauen Tooltip bekommst mit "gametip.hidegametip" in der Console (Client Console) weg...
      Das Decaying rechts unten bekommste gar nicht weg. Aber das gebäude zerfällt nicht.

      Du kannst zusätzlich noch "upkeep_period_minutes 999999999" extrem hoch setzten dann sind die UpKeep kosten sehr gering. Evt. reicht es dann wenn von jedem Rohstoff 1 drinne ist damit die Meldung nicht mehr angezeigt wird.


      Wipen musst du da nicht. Die einstellungen werden sofort übernommen.
    • Die Bauteile scheinen nun jedenfalls nicht mehr zu zerfallen auch wenn kein Material im Werkzeugschrank ist ja.
      Ich werde auch noch "+upkeep_period_minutes 999999999" ins Script schreiben und sehn was passiert.
      Vielen dank für die tollen Tipps und die Hilfe :)

      EDIT: Merkwürdigerweise sind Teile die nach der Änderung gesetzt wurden nicht vom Decay ausgenommen und fangen sofort an zu verfallen. Das soll einer verstehen

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Brave Jake ()

    • Wenn du dich als Admin angemeldet hast, kannst du in der Console unter F1 diesen parameter decay.scale 0 einstellen dann ist der Zerfall ausgestellt,
      decay.scale 0 "0" steht für false/nicht erlaubt
      decay.scale 1 "1" steht für true/erlaubt

      Aber diese Seite wird dir bestimmt weiter helfen :)
      Rust Dedicated Server Parameter

      Oder willst du es allgemein verlangsamen ?
      █▄█▄█ -----SqKn----- █▄█▄█
      ▐█┼█▌█▄█▄█▄█▄█▐█┼█▌
      ▐███▌█┼█╔═╗█┼█▐███▌
      ▐███▌███║▓║███▐███▌

      ¸.•´¸.•*¨) ¸.•*¨) (`’·.¸(`’·.¸ ¸.·’´) ¸.·’´) (¨*•.¸ (¨*•.¸`•.¸
      (¸.•´ (¸.•´ .•´ ¸¸.•¨¯`• •`¯¨• ¸¸ `•. `•.¸) `•.¸)
      Projekterfolg ist kein Zufall!