Plugin QuickSmelt

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Plugin QuickSmelt

      Hallo,

      ich habe folgendes Problem, ich habe mir die Tage einen Rust Server gemietet und Plugins darauf installiert bis jetzt haben alle einwandfrei funktioniert.

      Doch bei QuickSmelt sieht es anders aus, jedesmal wenn ich irgendwelche Änderung in der Config Datei vornehme und dann den Server starte resetet sich die Config datei.

      Ich bin mit meinem Latein am ende kann auch sein das das Problem sehr einfach zu lösen ist, aber ich finde es nicht und die permission befehle (falls die überhaupt nötig sind, weil ich mehrere male gelesen habe das es sofort für jeden freigeschaltet ist) funktionieren nicht. Ich bitte dringend um Hilfe.


      Die Config Datei sieht wie folgt aus :



      _____________________________________


      {
      "Permission": "quicksmelt.use",
      "Use Permission": true,
      "Speed Multipliers": {
      "furnace.shortname": 1.0
      },
      "Fuel Usage Speed Multipliers": {
      "furnace.shortname": 1.0
      },
      "Fuel Usage Multipliers": {
      "furnace.shortname": 1
      },
      "Output Multipliers": {
      "furnace.shortname": {
      "item.shortname": 1.0
      }
      },
      "Whitelist": {
      "furnace.shortname": [
      "item.shortname"
      ]
      },
      "Blacklist": {
      "furnace.shortname": [
      "item.shortname"
      ]
      },
      "Smelting Frequency (Smelt items every N smelting ticks)": 2,
      "Debug": false
      }

      _________________________________________

      jegliche Änderung werden beim Serverstart oder beim reload gelöscht und es kommt wieder die gezeigte Config.

      danke im vorraus

      euer Daniel / Katakuri

    • Hey, wie meinst du das mit einem Schreibschutz? wir sind in rust/oxide/config/QuickSmelt.json gegangen haben es da schon andere sachen eingefügt und gespeichert , der server hat dann auch error angezeigt und es zurück gesetzt kann dir jetz aber leider nicht sagen was fürn error kannst du helfen?
    • Hab jetz eine Error datei gefunden die heißt QuickSmelt.jsonError darin steht


      {
      "Permission": "quicksmelt.use",
      "Use Permission": true,
      "Speed Multipliers": {
      "furnace.shortname": 1.0
      },
      "Fuel Usage Speed Multipliers": {
      "furnace.shortname": 1.0
      },
      "Fuel Usage Multipliers": {
      "furnace.shortname": 1
      },
      "Output Multipliers": {
      "furnace.shortname": {
      "item.shortname": 1.0
      }
      },
      "Whitelist": {
      "furnace.shortname": [
      "item.shortname"
      ]
      },
      "Blacklist": {
      "furnace.shortname": [
      "item.shortname"
      ]
      },
      "Smelting Frequency (Smelt items every N smelting ticks)": 2,
      "Debug": true
      }
    • rustgaming.net schrieb:

      Servus, was zeigt der Server beim Starten an? Any Logs? Hast Du es dreist mit einem Schreibschutz auf der Config getestet? Was meldet oxide wenn Du

      Quellcode

      1. oxide.reload QuickSmelt
      in die Console eingibst?
      mit dem reload befehl hab ich es auch schon probier, leider kein erfolg. Die schreibgeschützte Datei wird auch überschrieben.

      Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von katakuri ()

    • OK, dann hast Du ja mittlerweile schon ein wenig getestet...
      Siehst Du das Serverlog bei deinem Anbieter? Schon getestet, ob es funktioniert wenn Du dir eine frische Kopie des Plugins ziehst (ggfs. hast Du ausversehen etwas ungewollt geändert...)

      Gerade gesehen: "Debug: true" - d.h. es gibt einen switch, ggfs. sollte der auf false gesetzt werden.
      Join rustgaming.net:28015
      Visit rustgaming.net
      Teamspeak Server
      Fragen und Anregungen zum Server: gerne per PM oder website