Rust+ immer wieder neu Verbinden

  • Hallo

    Wir haben vorkurzem einen eigen Rust Server erstellt.

    Nun haben wir das Problem das wir uns jedes mal neu mit der Rust+ App verbinden müssen sobald der Server einen Restart macht.

    Ich habe in der Server.cfg schon app.port und app.puplicid hinein geschrieben.

    Im Netz habe ich einen Beitrag gelesen in dem stand das man den Server port +1 nehmen soll. Doch wenn ich dies tue dann kann ich keine Verbindung mit der App auf bauen.

    Würde mich über eine Lösung freuen.

  • Hallo,


    wir haben auch oft festgestellt das der app.port nicht immer über die server.cfg funktioniert, daher am besten via Stardparameter mitgeben.


    Bei der Regel Gameport + 1 gibt es viele Meinungen im Inet, der eine schreibt +1 der nächste +100 der andere schreibt Gameport + 67. Wir haben die +67 genommen funktioniert mit dem Parameter in der Komandozeile.

  • Hallo

    Also ich hatte den Port immer 1+ genommen.

    Mittlerweile glaube ich das es an unserem Hosting Anbieter liegt. Da unsere Server jeden Tag einen restart macht und somit die App keine Verbindung mehr bekommt.

    Ich danke euch trotzdem für die Antworten

  • der Port sollte vom Anbieter in den Startparametern mitgegeben werden. Wir haben auch schon Erfahrungen gemacht das es in einigen Fällen via Config nicht funktioniert hat. Hier den Anbieter kontakltieren das er dies übernehmen soll. Zusätzlich würde ich trotzdem empfehlen diesen nicht direkt +1 zu lassen + 10 oder so. Oftmals kommt es zu Konflikten, da ein Spiel nicht nur den offensichtlichen Gameserverport benötigt.